在线检测未来函数

阻力线指标改成大智慧

来源:Internet,编辑:股旁网,2012-05-22

编写要求:

股旁网解答:

 网友求助:

三十线:ma(c,30);
六十日线:ma(c,60);
临界线:=WMA(CLOSE,13);
VAR1:=POW(CLOSE-临界线,1);
VAR2:=MA(VAR1,13);
VAR3:=SQRT(VAR2);
阻力线:临界线+1.96*VAR3;
支撑线:临界线-1.96*VAR3;
PARTLINE(临界线>REF(临界线,1) AND 阻力线<>支撑线,临界线),COLORRED,LINETHICK2;
PARTLINE(临界线<REF(临界线,1),临界线),LINETHICK2;
PARTLINE(阻力线=支撑线,临界线),LINETHICK2,colorFF0000;

VAR4:=(CLOSE+HIGH+LOW)/3;
VAR5:=EMA(VAR4,13);
VAR6:=REF(VAR5,1);
STICKLINE(VAR5>VAR6,VAR5,VAR6,5,0),CoLor00FFFF;
STICKLINE(VAR5<VAR6,VAR5,VAR6,5,0),CoLorFF0000;

 
解答如下:
三十线:MA(C,30);
六十日线:MA(C,60);
临界线:WMA(CLOSE,13);
VAR1:=POW(CLOSE-临界线,1);
VAR2:=MA(VAR1,13);
VAR3:=SQRT(VAR2);
阻力线:临界线+1.96*VAR3;
支撑线:临界线-1.96*VAR3;
IF(临界线>=REF(临界线,1),临界线,DRAWNULL),COLORRED,LINETHICK2;
IF(临界线<REF(临界线,1),临界线,DRAWNULL),LINETHICK2;
IF(阻力线=支撑线,临界线,DRAWNULL),LINETHICK2,COLORFF0000;
VAR4:=(CLOSE+HIGH+LOW)/3;
VAR5:=EMA(VAR4,13);
VAR6:=REF(VAR5,1);
STICKLINE(VAR5>VAR6,VAR5,VAR6,3,0),COLOR00FFFF;
STICKLINE(VAR5<VAR6,VAR5,VAR6,3,0),COLORFF0000;
 

 

相关文章

股票公式月点击榜

股票公式年点击榜

股票公式总点击榜